Go without losing your work!

Recently, Oracle released Java 1.7.0_51 which now officially prevents unsigned AND self-signed applets from running, or applets without a proper permissions attribute. You can read more about it here.

This means that any applets you try to run from www.compilejava.net will be blocked if you are using Java 1.7.0_51. All non-applet programs compiled here do NOT require this. They don't even require you having Java.

Here is a workaround, as written by Oracle...


As a workaround, the user can use Exception Site list feature to run the applications blocked by security settings. By adding the URL of the blocked application to the Exception Site list allows it to run with some warnings.

Steps to Add URL to the Exception Site list:


Notes: you may simply be able to just drag the security slider from "HIGH" (default) to "MEDIUM"